[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 2
  • 1
  • 2
  • »
Форум » Обсуждение программы АРМ "Скиф" » Ошибки программы » Проблемы версии 2.4?
Проблемы версии 2.4?
FlyJДата: Вторник, 14.10.2014, 22:15 | Сообщение # 1
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
на win7 установил версию 2.4. Настроил сервер, на этом же ПК запускаю клиент. Подключение к серверу и авторизация оператора есть, а управлять приборами и читать события с пульта не получается. Скажите, пожалуйста, эта проблема в новой версии, настройках пульта или настройках сервера?
Прикрепления: 5987439.png(37.0 Kb) · 8225682.png(46.2 Kb) · 4481161.png(60.9 Kb)
 
arm-skifДата: Вторник, 14.10.2014, 23:46 | Сообщение # 2
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Скорее всего ошибка в подключении или в настройке пульта. Пульт виден в pprog? Проверьте в настройках пульта скорость 9600, адрес 127, режим "Компьютер".
 
FlyJДата: Среда, 15.10.2014, 14:34 | Сообщение # 3
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Вроде все настройки корректны. В режиме принтер данные на com порт шлет, проверял через hyperterminal. Посмотрю вечером еще раз настройки пульта и попробую старую версию сервера.
 
arm-skifДата: Среда, 15.10.2014, 14:38 | Сообщение # 4
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Для режима "принтер" применяется другой кабель (другая распиновка DB9). Проверьте именно программой pprog - должна считывать данные.
 
arm-skifДата: Среда, 15.10.2014, 15:00 | Сообщение # 5
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Распиновка (пульт-DB9)

Для гипертерминала:
TxD - 2
DTR - 4
GND - 5

Для программы:
TxD - 2
DTR - 3
GND - 5
 
FlyJДата: Среда, 15.10.2014, 20:04 | Сообщение # 6
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Цитата arm-skif ()
Для программы: TxD - 2
DTR - 3
GND - 5


Действительно, в этом была проблема. На днях менял провод и видимо спаял не по той схеме. спасибо.
 
arm-skifДата: Среда, 15.10.2014, 20:08 | Сообщение # 7
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Пожалуйста.
 
FlyJДата: Среда, 15.10.2014, 22:26 | Сообщение # 8
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
и еще вопрос, что означают следующие сообщения об ошибках в лог файле?

Видимо из за этого я не могу подключится к серверу через web
Я так понимаю занят какой либо адрес (или порт), но команда netstat выдает следующее
Прикрепления: 8029742.png(44.6 Kb) · 6423258.png(34.8 Kb)


Сообщение отредактировал FlyJ - Среда, 15.10.2014, 22:27
 
arm-skifДата: Среда, 15.10.2014, 22:33 | Сообщение # 9
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Порты заняты, скорее всего пытаетесь запустить второй сервер.
 
arm-skifДата: Среда, 15.10.2014, 22:37 | Сообщение # 10
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Чтобы подключиться по быстрому через web, создайте в конфигураторе АРМ с идентификацией по IP: 127.0.0.0 и паролем 123456. Можно с идентификацией по ARMID: testId и паролем 123456.
 
FlyJДата: Четверг, 16.10.2014, 21:03 | Сообщение # 11
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
вытащил с образа RPi сервер skif и из /var/www файлы для websocket. Положил на своей RPi в аналогичные каталоги. Сервер skif на Rpi запускается. Gui клиентом из Windows по сети подключаюсь к серверу, а через Web-интерфейс - нет. При запуске сервера на Windows и подключении через web - все работает отлично. Буду экспериментировать, может в версии 2.4 добавились какие-либо библиотеки qt, а они у меня не установлены? На текущий момент установлены  libqt4-core, libqt4-gui, libqt4-network, qtserialport, libqt4-dev
Хотя ошибок при запуске сервера нет.
 
arm-skifДата: Четверг, 16.10.2014, 21:47 | Сообщение # 12
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Файлы скифа, помимо образа, можно брать здесь.

Давайте разбираться.
В конфигураторе настроен АРМ? Идентификация по IP или ARMID? Пароль какой? Для начала лучше установить пароль 123456.
В файле WebSocket/config.js какие настройки? Если открыть в браузере work.htm, то что пишет на этой страничке в разделе "Лог программы" (Попытка подключения...)? Что на сервере в файле log/ServerSkif_webSocket.log?

Скорее всего не настроен IP в WebSocket/config.js. В моей сборке для rpi, при настройке в клиентском ПО ip адреса, меняется ip так же в config.js.

Из библиотек вроде должна быть еще libqt4-script, но она не влияет на вебсокет. Попробуйте записать на SD карту мой образ и зайти браузером на адрес rpi.
 
FlyJДата: Пятница, 17.10.2014, 22:43 | Сообщение # 13
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
в конфигураторе на windows настроен сервер. добавлен план, идентификация по ip. ip адрес 127.0.0.1, пароль 123456.
Сервер запускается на rpi ощибок в логах нет. на сервер перенес папку base с конфигурацией (время 0.26)

config.js настроен и вместе с work.htm в корневой директории веб-сервера lighhtpd.
Хэш совпадает с паролем 123456

На веб странице попытка подключения и не более того.


qtscript - установлен.
Пока пробую все на своем образе RPi.
Прикрепления: 0562762.png(40.7 Kb) · 6938824.png(35.1 Kb) · 6333587.png(86.9 Kb) · 0036411.png(34.8 Kb)


Сообщение отредактировал FlyJ - Пятница, 17.10.2014, 22:44
 
arm-skifДата: Пятница, 17.10.2014, 23:23 | Сообщение # 14
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
На windows работает, потому что браузер к серверу подключается по локальному адресу 127.0.0.1.

Если сервер на одном компьютере, а браузер на другом, то в config.js нужно прописать ip адрес сетевой карты первого компьютера (где сервер). Браузер является клиентом, и должен знать куда подключиться.

В config.js нужно записать ip адрес сетевой карты rpi (только внешний, а не 127.0.0.1). Добавить АРМ с ip адресом windows и паролем 123456.

Например:
10.8.1.20 - ip windows
10.8.1.3 - ip rpi
в config.js должна быть строка: wsUri = "ws://10.8.1.3:54322";
в конфигураторе добавить АРМ с ip 10.8.1.20.
 
FlyJДата: Суббота, 18.10.2014, 00:19 | Сообщение # 15
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
windows клиент - 10.8.1.20
rpi сервер - 10.8.1.3
1. сервер 10.8.1.3 запущен, gui клиент на win 10.8.1.20 -подключение в норме. Авторизация по IP

2. настраиваем config.js на win (10.8.1.20)
пытаюсь с win машины подключится

3. Аналогично пробую на сервере настроить файл config.js и запросить страничку у веб сервера с win машинки




В логах ничего не появилось, где еще можно ошибки отлавливать? 
Спасибо!
Прикрепления: 3350707.png(37.0 Kb) · 4864459.png(89.2 Kb) · 2488007.png(87.4 Kb) · 5621259.png(66.3 Kb) · 0277903.png(34.9 Kb)
 
arm-skifДата: Суббота, 18.10.2014, 00:28 | Сообщение # 16
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Настройки правильные.

Посмотрите в файле Base/config.ini порт "webPort=54322". Этой строки там может и не быть, тогда порт по умолчанию 54322.

Может виндовый брандмауэр втихоря блокирует. Отключите его временно.
 
FlyJДата: Суббота, 18.10.2014, 08:55 | Сообщение # 17
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
((( увы. Брандмауэр был отключен, отключил еще и касперского, настройки config.ini корректны webport=54322, serverport=54321
 
arm-skifДата: Суббота, 18.10.2014, 10:47 | Сообщение # 18
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Пока не понимаю причину. Что-то мешает браузеру подключиться к серверу. Если бы была попытка, то в файле ServerSkif_webSocket.log была бы запись об этом.

Записал мой образ для rpi на SD карту, загрузился, и ничего не настраивая (даже не подключал клавиатуру и монитор), подключился браузером на адрес 192.168.10.222:


Только нужно подождать когда сервер скифа запустится. Первый раз немного дольше обычного. Вебсервер запускается раньше скифа.
Прикрепления: 0076853.png(65.6 Kb)
 
FlyJДата: Суббота, 18.10.2014, 11:49 | Сообщение # 19
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Попробовать сторонним средством подключится на порт 54322. Посмотреть что на него приходит.
 
arm-skifДата: Суббота, 18.10.2014, 11:55 | Сообщение # 20
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
А можете проделать то же что и я в посте №18?

Может браузер по какой-то причине подключатся только на локальные адреса. Проверьте, подключается ли на этой страничке: http://www.websocket.org/echo.html

Еще можно попробовать другим браузером.
 
FlyJДата: Воскресенье, 19.10.2014, 16:57 | Сообщение # 21
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Цитата arm-skif ()
А можете проделать то же что и я в посте №18?
С вашим образом все работает.
Прикрепления: 2075777.png(91.8 Kb) · 2585614.png(133.9 Kb)
 
arm-skifДата: Воскресенье, 19.10.2014, 17:04 | Сообщение # 22
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Вот поэтому я не понимаю причину. У вас все правильно настроено и должно работать  wacko
 
FlyJДата: Воскресенье, 19.10.2014, 17:07 | Сообщение # 23
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Цитата arm-skif ()
Вот поэтому я не понимаю причину. У вас все правильно настроено и должно работать
раз проблема не клиенте, не в маршрутизаторе и не в конфигурации - остается сервер.
Видимо я некорректно перенес Ваше ПО на свой образ pi.
Как-то можно проследить, что уходит с клиента, что и куда приходит на сервер?
 
arm-skifДата: Воскресенье, 19.10.2014, 17:12 | Сообщение # 24
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Все же возможно виноват браузер. В сообщении № 21 на второй картинке, после надписи SENT, должна быть надпись RESPONSE. Сейчас что-то этот эхо тест работает только в режиме "Use secure WebSocket (TLS)" (с установленной галочкой).
 
arm-skifДата: Воскресенье, 19.10.2014, 17:17 | Сообщение # 25
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Цитата FlyJ ()
Как-то можно проследить, что уходит с клиента, что и куда приходит на сервер?

Не знаю как это можно сделать сторонними средствами. Если бы к серверу что-то подключилось на его порты, то это обязательно было бы в логах. Обмены в хромиуме я смотрю по F12 (или ctrl+shift+i).
 
FlyJДата: Воскресенье, 19.10.2014, 17:38 | Сообщение # 26
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Цитата arm-skif ()
Сейчас что-то этот эхо тест работает только в режиме "Use secure WebSocket (TLS)" (с установленной галочкой).
 CONNECTED
 SENT: Rock it with HTML5 WebSocket
 RESPONSE: Rock it with HTML5 WebSocket
 DISCONNECTED

Добавлено (19.10.2014, 17:38)
---------------------------------------------
командой 

Код
telnet 10.8.1.3 54322
 подключаюсь т.е. порт открыт, ожидает посылки команды
 
FlyJДата: Воскресенье, 19.10.2014, 17:57 | Сообщение # 27
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
вот такую вещь обнаружил в консоле

смотрим 34 строку в main.js

Так понимаю не удается создать объект?
Прикрепления: 2802623.png(69.1 Kb) · 0600180.png(110.7 Kb)
 
arm-skifДата: Воскресенье, 19.10.2014, 19:42 | Сообщение # 28
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Так а почему яваскрипт пытается подключиться на порт 44444?  smile
Может в config.js какой-то скрытый символ в строку попал и порт получается не 54322, а 44444. Попробуйте перенабрать строку wsUri = "ws://10.8.1.3:54322";
 
FlyJДата: Воскресенье, 19.10.2014, 20:30 | Сообщение # 29
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Это я эксперементировал, думал в порту проблема.серверу сделал 55555, websocket 44444. Gui клиент, все также подключается по порту 55555, web -нет. Могу исправить на стандартные настройки.
 В файле main.js срабатывает событие websocket.onclose
Также проверял работу в браузерах firefox, safari. Результат тот же

Добавлено (19.10.2014, 20:30)
---------------------------------------------
А какие то настройки web сервера нужны для работы websocket?


Сообщение отредактировал FlyJ - Воскресенье, 19.10.2014, 20:32
 
arm-skifДата: Воскресенье, 19.10.2014, 20:34 | Сообщение # 30
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Браузер через WebSocker подключается напрямую к серверу скифа (минуя web сервер). Мне кажется что это какая-то несовместимость в Qt. Подумаю в чем может быть причина.
 
FlyJДата: Воскресенье, 19.10.2014, 20:35 | Сообщение # 31
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
У вас же qt 4 версии?
 
arm-skifДата: Воскресенье, 19.10.2014, 20:36 | Сообщение # 32
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Да.

Может мне сделать сборку linux с нужным вам ПО?
 
FlyJДата: Воскресенье, 19.10.2014, 20:46 | Сообщение # 33
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Если решения этой проблемы не найдется, думаю, подкорректирую Ваш образ. Доустановлю необходимое ПО.
 
arm-skifДата: Воскресенье, 19.10.2014, 21:08 | Сообщение # 34
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Доустановить ПО проблематично. В сборке нет пакетного менеджера. Можно включить в состав ipkg/opkg, но я с ними не работал. Мне проще сразу включить в состав что нужно.
 
arm-skifДата: Воскресенье, 19.10.2014, 21:59 | Сообщение # 35
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Установил для сокета  параметр NoProxy. Попробуйте.
Прикрепления: ServerSkif_240_.7z(222.1 Kb)
 
FlyJДата: Понедельник, 20.10.2014, 18:53 | Сообщение # 36
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Проверил, увы, не работает.
Изменил порт на стандартный
Прикрепления: 8802289.png(105.6 Kb) · 1543797.png(98.9 Kb)


Сообщение отредактировал FlyJ - Понедельник, 20.10.2014, 18:54
 
arm-skifДата: Понедельник, 20.10.2014, 20:05 | Сообщение # 37
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
А в каком дистрибутиве linux у вас работает программа? Мне бы воспроизвести эту проблему у себя, я так быстрее пойму что к чему.
 
FlyJДата: Понедельник, 20.10.2014, 20:33 | Сообщение # 38
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
wheezy-raspbian

Может мне сделать образ своей карточки?
 
arm-skifДата: Вторник, 21.10.2014, 06:47 | Сообщение # 39
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Пока не надо, я сначала попробую на скачанной с интернета.
 
arm-skifДата: Суббота, 25.10.2014, 12:51 | Сообщение # 40
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
На wheezy-raspbian не пойму куда закинуть библиотеку libQtSerialPort. Пробовал в /usr/lib, /usr/lib/arm-linux-gnueabihf, /lib. Не находит.

Сделайте свой образ, я попробую на нем.
 
FlyJДата: Суббота, 25.10.2014, 15:08 | Сообщение # 41
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
случайно удалил последнее сообщение((
с вашего образа из папки/usr/skif я беру файлы программы (сервер и конфигуратор сервера), кладу в аналогичную папку на малине.
2. В Файл Init.d (inittab)прописываю запуск сервера
null::respawn:/usr/skif/watchdog
null::respawn:/usr/skif/ServerSkif
3. Сохраняю файл в папку /root/.directfbrc
apt-get install libqt4-dev libqt4-core, libqt4-gui, libqt4-network
git clone git://gitorious.org/qt/qtserialport.git

qmake qtserialport.pro
make
make install
(http://qt-project.org/wiki/QtSerialPort_Russian#34abf068d06fef0334f26fa55b4479c2)


Сообщение отредактировал FlyJ - Суббота, 25.10.2014, 15:16
 
arm-skifДата: Суббота, 25.10.2014, 15:11 | Сообщение # 42
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Ну теперь понятно. Библиотека не захотела работать с установленной qt, потребовалась пересборка.
 
arm-skifДата: Воскресенье, 26.10.2014, 01:28 | Сообщение # 43
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Оказывается статическая библиотека не одно целое с программой, а как бы отдельно (почти как динамическая, только в одном исполняемом файле). В программе используется библиотека QtWebSocket, которую я собрал статически из-за того, что она не доделана для Windows (не оформлены экспортируемые функции для dll). Для liunx можно собрать динамически, но вашим методом не получилось (корявая библиотека). Пришлось установить на raspbian qtcreator и обработать напильником. В архиве сервер и библиотека. Библиотеку скопируйте в /usr/lib/arm-linux-gnueabihf/.

В Qt5 уже есть эти две библиотеки. Когда-нибудь с ними не придется так возиться.

Кстати файл /root/.directfbrc и библиотека libqt4-gui нужны только для клиента.
Прикрепления: skifs_raspbian..lzma(227.8 Kb)
 
FlyJДата: Воскресенье, 26.10.2014, 10:07 | Сообщение # 44
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Цитата arm-skif ()
В архиве сервер и библиотека. Библиотеку скопируйте в /usr/lib/arm-linux-gnueabihf/

Спасибо. в архиве только файл skifs_raspbian 920кб - это и есть библиотека?
Сервера нет. Если оставляю старый сервер, скоприовав библиотеку по указанному пути, ошибка остается.
 
arm-skifДата: Воскресенье, 26.10.2014, 10:13 | Сообщение # 45
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Это двойной архива, на raspbian вроде нормально распаковывается. На всякий случай перепаковал.

ps
Сервер сократил имя архива с skifs_raspbian.tar.lzma до skifs_raspbian..lzma, поэтому не распаковывается. Не заметил.
Прикрепления: skifs_raspbian.7z(229.1 Kb)
 
FlyJДата: Воскресенье, 26.10.2014, 13:04 | Сообщение # 46
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
скопировал файлы libQtWebsocket.so.1.0.0 libQtWebsocket.so.1.0 libQtWebsocket.so.1 libQtWebsocket.so в каталог /usr/lib/arm-linux-gnueabihf/, но при запуске сервера ошибка загрузки библиотек error while loading shared libraries: /usr/lib/arm-linux-gnueabihf/libQtWebsocket.so.1: file too short

Сервер взял тоже из архива.

Цитата arm-skif ()
В программе используется библиотека QtWebSocket,


По ссылке скачал библиотеку, попробовал собрать, но


Код
root@SmartHome:/home/pi/share/skif 2.4.0 pi/qtwebsocket-qtwebsocket# make
cd QtWebsocket/ && make -f Makefile
make[1]: Entering directory `/home/pi/share/skif 2.4.0 pi/qtwebsocket-qtwebsocket/QtWebsocket'
g++ -c -pipe -O2 -fPIC -Wall -W -D_REENTRANT -DQT_WEBKIT -DQT_NO_DEBUG -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4 -I. -o QWsServer.o QWsServer.cpp
In file included from QWsServer.h:37:0,
                  from QWsServer.cpp:20:
QTlsServer.h:63:34: error: ‘qintptr’ has not been declared
make[1]: *** [QWsServer.o] Error 1
make[1]: Leaving directory `/home/pi/share/skif 2.4.0 pi/qtwebsocket-qtwebsocket/QtWebsocket'
make: *** [sub-QtWebsocket-make_default] Error 2
 
arm-skifДата: Воскресенье, 26.10.2014, 13:49 | Сообщение # 47
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
Странно, у меня работает. Неужели у нас разные дистрибутивы surprised . Во вложении исправленная QtWebsocket, но у меня собирается только в qtcreator.

libQtWebsocket.so.1 - это ссылка на libQtWebsocket.so.1.0.0
может ссылка поломалась?

Можно попробовать переименовать
libQtWebsocket.so.1.0.0 в libQtWebsocket.so.1
Прикрепления: QtWebsocket.7z(14.8 Kb)
 
FlyJДата: Воскресенье, 26.10.2014, 15:28 | Сообщение # 48
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн

Спасибо огромное. Все заработало. скачал Ваш архив с 47 поста,
qmake
make
в итоге получил файлы и положил в папку. все запустилось. Могу в ближайшее время все повторить и выложить здесь инструкцию, вдруг кому пригодится.
Прикрепления: 9742990.png(58.3 Kb)
 
arm-skifДата: Воскресенье, 26.10.2014, 15:32 | Сообщение # 49
Группа: Администраторы
Сообщений: 660
Репутация: 27
Статус: Оффлайн
И вам спасибо за старания. Могу подарить лицензию на rpi на 10 приборов. Если нужно конечно. В инструкции на rpi написано где взять серийный номер.
 
FlyJДата: Суббота, 01.11.2014, 15:58 | Сообщение # 50
Группа: Проверенные
Сообщений: 64
Репутация: 3
Статус: Оффлайн
Цитата FlyJ ()
Могу в ближайшее время все повторить и выложить здесь инструкцию, вдруг кому пригодится
skif2.4

1.  C образа из папки/usr/skif  берем файлы программы (папка skif, сервер),кладем в аналогичную папку на малине.

2. Устанавливаем необходимые библиотеки
Код
apt-get install libqt4-dev libqt4-core libqt4-network


3. Собираем qtserialport
скачиваем в текущую папку
Код
git clone git://gitorious.org/qt/qtserialport.git

переходим в созданную директорию
Код
cd qtserialport

собираем и устанавливаем
Код
qmake qtserialport.pro
     make   
     make install

4. установка QtWebsocket
переходим в папку QtWebsocket и выполняем команды
Код
qmake
make

копируем созданные ярлыки в папку /usr/lib/arm-linux-gnueabihf
libQtSerialPort.so
libQtSerialPort.so.1
libQtSerialPort.so.1.0
libQtSerialPort.so.1.0.0

5. Переносим конфигурацию на сервер (папка skif/base), предварительно создав в конфигураторе сервера.

6. Переносим каталог WebSocket в корне Web-сервера, настроив файл config.js

7. Настраиваем автозапуск

В Файл /etc/inittab прописываю запуск сервера
ln -s /dev/ttyUSB0 /dev/COM6 создание ком порта (в конфигураторе переходник usb-com я настроил на com6)
null::respawn:/usr/skif/watchdog (таймер контроля зависаний)
null::respawn:/usr/skif/ServerSkif


Сообщение отредактировал FlyJ - Суббота, 01.11.2014, 15:59
 
Форум » Обсуждение программы АРМ "Скиф" » Ошибки программы » Проблемы версии 2.4?
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Форма входа
Наш опрос
Для какой ОС будет востребована программа:
Всего ответов: 701
Статистика